Autor Téma: Nepřipojí se automaticky disky NAS při startu počítače  (Přečteno 253 krát)

martas38

  • Newbie
  • *
  • Příspěvků: 30
  • Karma: +1/-0
    • Zobrazit profil
Zdravím. Pořídil jsem NAS Synology a při startu systému se automaticky nepřipojí pomocí nfs síťové disky. Disky mám namapovány v fstab do adresářů v /home. Při restartu počítače vše funguje jak má, ale při studeném startu se nepřipojí. Řekl bych, že je tím, že ještě neběží síťové služby, protože po přihlášení do KDE mně teprve NET applet ukáže, že "Síť běží na...". Když dám po té mount -a disky se normálně připojí, rovněž ruční připojení mount -r funguje. Lze nějak v fstab nastavit zpoždění připojení síťových disků třeba o 10 sekund, až poběží síť, nebo to řešit nějakým scriptem při startu?
Ještě bych dodal, že NAS běží a disky nespí a že se jedná o Mageia 6.

alda81

  • Sr. Member
  • ****
  • Příspěvků: 435
  • Karma: +17/-0
    • Zobrazit profil
    • aldacerny.cz
Re:Nepřipojí se automaticky disky NAS při startu počítače
« Odpověď #1 kdy: Srpen 02, 2018, 18:30:28 »
nemám odzkoušeno, ale mělo by fungovat přidat do řádku v fstabu s daným diskem parametr
Kód: [Vybrat]
_netdevvíce v man mount
_netdev - The  filesystem  resides on a device that requires network access (used to prevent the system from attempting to mount these filesystems until the network has been enabled on the system).

pokud by to nefungovalo, tak další možný parametr (x-systemd.after=network-online.target) je popsaný třeba zde https://unix.stackexchange.com/questions/349264/fstab-mount-wait-for-network 

Nutné čtení pro všechny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru

Joelp

  • Administrator
  • Sr. Member
  • *****
  • Příspěvků: 416
  • Karma: +11/-0
    • Zobrazit profil
    • Joelp's blog
Re:Nepřipojí se automaticky disky NAS při startu počítače
« Odpověď #2 kdy: Srpen 06, 2018, 18:44:24 »
Mě funguje s tímto ve fstab:
Kód: [Vybrat]
nas:/volume1/video /home/joelp/Videa/storage/ nfs wsize=8192,rsize=8192,nosuid,soft,nofail 0 0

Místo nas zadej IP adresu. Já mám lokální DNS server.