Autor Téma: [Vyřešeno]Skrýt nechtěné aktualizace  (Přečteno 2244 krát)

rumany

  • Newbie
  • *
  • Příspěvků: 8
  • Karma: +0/-0
    • Zobrazit profil
[Vyřešeno]Skrýt nechtěné aktualizace
« kdy: Leden 03, 2014, 21:44:56 »
Dobrý den, prosím, nechci aktualizovat firefox. Dá se nějak nastavit, aby byla podržena stávající verze? Za rady předem děkuji.
Ruda

EDIT: [Vyřešeno]
« Poslední změna: Leden 04, 2014, 15:04:13 od Yullaw »

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #1 kdy: Leden 03, 2014, 22:28:15 »
Pod rootem, například pomocí Krusader s právy roota (KMenuNástrojeSystémové nástrojeRežim Krusaderu s právy roota) uprav /etc/urpmi/skip.list, kde dosaď jen název programu / balíčku.

Výsledek bude takto:
Kód: [Vybrat]
# Here you can specify the packages that won't be upgraded automatically
# for example, to exclude all apache packages :
# /^apache/
/^firefox/

Ovšem musím upozornit na to, že by se Firefox měl aktualizovat, z důvodu bezpečnosti.

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

rumany

  • Newbie
  • *
  • Příspěvků: 8
  • Karma: +0/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #2 kdy: Leden 04, 2014, 08:10:13 »
Moc děkuji, funguje. Chci zatím nechat firefox 17ESR. Jestli jsem to dobře pochopil je to verze s dlouhodobou podporou, takže by to snad mělo být bezpečné. Správce sw mi stejně nabízel pouze firefox 24 a nejnovější je 26. Mimochodem firefox 26 mám vyzkoušený, a je vynikající. To mně vede k otázce, kdy bude ve správci sw firefox 26? Vyzkoušel sem několik různých dister linuxu a z nějakého záhadného důvodu mi ve všech na některých stránkách firefox drhne. Tato verze 17 to kupodivu nedělá.

alda81

  • Sr. Member
  • ****
  • Příspěvků: 435
  • Karma: +17/-0
    • Zobrazit profil
    • aldacerny.cz
Re:Skrýt nechtěné aktualizace
« Odpověď #3 kdy: Leden 04, 2014, 09:02:46 »
Chci zatím nechat firefox 17ESR. Jestli jsem to dobře pochopil je to verze s dlouhodobou podporou, takže by to snad mělo být bezpečné.
nemělo by to být bezpečné, bo podpora pro Firefox 17 esr skončila, pokud se podíváš sem https://wiki.mozilla.org/Enterprise/Firefox/ExtendedSupport:Proposal#Version_Numbers, tak zjistíš, že aktualizace pro Firefox s číslem 17 se přestaly vydávat 3. prosince 2013, další verzí s dlouhodobou podporou je verze 24, taky to zjistíš z uvedené stránky, takže tím myslím odpovídám i na tvou otázku, kdy se objeví verze 26 v Mageii >> nikdy

jen bych ještě doplnil, že pokud si zakážeš aktualizace, tak by se ti ani nezaktualizoval Firefox, který by měl tu dlouhodobou podporu (za předpokladu, že by mu nevypršela), takže by to zase nebylo bezpečné

pokud bys chtěl bezpodmínečně používat poslední Firefox, tak si můžeš kupříkladu stáhnout ze stránek https://www.mozilla.org/cs/firefox/features/ balíček s Firefoxem, ten rozbalit do svého domovského adresáře a z něj pouštět zatím poslední verzi tohoto prohlížeče - o aktualizace se ale budeš muset starat sám, půjde to mimo Mageia Control Center
Nutné čtení pro všechny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru

rumany

  • Newbie
  • *
  • Příspěvků: 8
  • Karma: +0/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #4 kdy: Leden 04, 2014, 10:07:43 »
Děkuji za velmi užitečné informace. Stáhl jsem firefox 26 dle Tvé rady, a přidal odkaz na plochu, abych ho mohl pohodlně spouštět. Funguje v pohodě, jen by mne zajímalo, jak dostat spouštěč na panel(KDE), to by bylo ještě lepší

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #5 kdy: Leden 04, 2014, 10:16:57 »
... jak dostat spouštěč na panel(KDE)...

jdi na svoji Plochu → vpravo nahoře klik na Plocha → Odemknout widgety → odkaz na aplikaci přetáhni na panel → opět Plocha → Uzamknout widgety (aby sis omylem nerozhodil panel ap.)

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

rumany

  • Newbie
  • *
  • Příspěvků: 8
  • Karma: +0/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #6 kdy: Leden 04, 2014, 11:02:32 »
Bohužel mi ten odkaz nejde přetáhnout na panel, vždy skočí zpět na plochu. Widgety odemčeny.

alda81

  • Sr. Member
  • ****
  • Příspěvků: 435
  • Karma: +17/-0
    • Zobrazit profil
    • aldacerny.cz
Re:Skrýt nechtěné aktualizace
« Odpověď #7 kdy: Leden 04, 2014, 13:48:33 »
když spustíš danou aplikaci, ve tvém případě přes ikonu na ploše, tak se ti v liště v KDE vytvoří malá ikona dané aplikace, pak klikni na tu ikonu pravým myšítkem a zvol Když neběží, ukázat pro něj spouštěč ...
Nutné čtení pro všechny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Skrýt nechtěné aktualizace
« Odpověď #8 kdy: Leden 04, 2014, 14:46:53 »
jdi na svoji Plochu → vpravo nahoře klik na Plocha → Odemknout widgety → odkaz na aplikaci přetáhni na panel → opět Plocha → Uzamknout widgety (aby sis omylem nerozhodil panel ap.)
Bohužel mi ten odkaz nejde přetáhnout na panel, vždy skočí zpět na plochu. Widgety odemčeny.
specielně vytvořeno pro tebe:
http://www.youtube.com/watch?v=7eiU_TFzxLA

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

rumany

  • Newbie
  • *
  • Příspěvků: 8
  • Karma: +0/-0
    • Zobrazit profil
[Vyřešeno]Re:Skrýt nechtěné aktualizace
« Odpověď #9 kdy: Leden 04, 2014, 14:56:39 »
alda81: Děkuji, to bylo ono. KDE je naprosto precisně vynikající věc(skoro), ale v každém distru jinak přiohnuté. Mageia má ten panel zvlášť extra spešl(ano, že si mohu navolit klasický panel vím). Jen pro zajímavost, Mageia3 KDE je první distro, které mi běhá bez problémů na 12 let starém stroji s Celeronem 2.4GHz a onboard GPU (samozřejmě bez efektů), i když by to vlastně papírově fungovat nemělo. Děkuji všem za pomoc, zase sem chytřejší. Tímto považuji toto téma za vyřešené. Ruda
Yullaw, děkuji, chyba byla asi v tom, že jsem v panelu už jeden spouštěč měl, ten pro versi17. Když jsem ho odstranil vše fungovalo. Původně sem si myslel, že tam budu mít oba, ale jaksi-nelze.

EDIT: [Vyřešeno]
« Poslední změna: Leden 04, 2014, 15:03:32 od Yullaw »