Autor Téma: [Vyřešeno]Qt - creator  (Přečteno 5351 krát)

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
[Vyřešeno]Qt - creator
« kdy: Prosinec 30, 2013, 19:17:12 »
Ahoj,

vznesu dotaz: instaloval někdo Qt creator?

mě se tam odmítá zobrazit instalovaná verze Qt, přitom v lib64 je po instalaci složka Qt5, kde jsou všechny soubory zapsané  v MCC k balíčku qt-creator.
Taky se v uvítací obrazovce nezobrazují příklady a taky jsou instalované ve výše uvedené složce.

pokud dám instalaci z qt-projekt.org - kde je tedy už verze5.2.0 ( v repo máme 5.0.2) do /opt/QT5/ tak se to objeví v pořádku, pouze je potřeba upravit práva u složky EXAMPLES - aby to neblblo pro normálního uživatele - bug je popsaný na qt-projekt.org

MGA3 64 bit kde nebo Lxde - (ne)funguje to stejně

EDIT:[Vyřešeno]
« Poslední změna: Leden 28, 2014, 21:00:14 od Yullaw »
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #1 kdy: Prosinec 30, 2013, 19:36:29 »
Ahoj,

co tak zkusit zdroje packages.mageialinux.ru :

32bit:
Kód: [Vybrat]
urpmi.addmedia --wget --distrib MageiaLinux.ru-i586- http://packages.mageialinux.ru/mageia3/i586/
64bit:
Kód: [Vybrat]
urpmi.addmedia --wget --distrib MageiaLinux.ru-x86_64- http://packages.mageialinux.ru/mageia3/x86_64/
kde:
Kód: [Vybrat]
[root@localhost yullaw]# urpmi qt-creator
Aby byly splněny závislosti, budou nainstalovány následující balíčky:
  Balíček                        Verze        Vydání        Arch.   
(zdroj "Core Updates (distrib3)")
  qt4-assistant                  4.8.5        1.2.mga3      x86_64  (navrhováno)
  qt4-designer                   4.8.5        1.2.mga3      x86_64  (navrhováno)
  qt4-doc                        4.8.5        1.2.mga3      noarch  (navrhováno)
(zdroj "packages.mageialinux.ru")
  qt-creator                     2.8.1        1.mga3.mrc    x86_64 
Navíc bude použito 357MB diskového prostoru.
Bude staženo 151MB balíčků.
Pokračovat v instalaci 4 balíčků? (A/n) n

info - pokud chci instalovat z oficiálních zdrojů, pak:
Kód: [Vybrat]
[root@localhost yullaw]# urpmi qt-creator
Aby byly splněny závislosti, budou nainstalovány následující balíčky:
  Balíček                        Verze        Vydání        Arch.   
(zdroj "Core Release (distrib1)")
  lib64qt5base5-devel            5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5bootstrap-devel        5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5concurrent-devel       5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5concurrent5            5.0.2        1.mga3        x86_64 
  lib64qt5core-devel             5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5core5                  5.0.2        1.mga3        x86_64 
  lib64qt5dbus-devel             5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5dbus5                  5.0.2        1.mga3        x86_64 
  lib64qt5declarative5           5.0.2        1.mga3        x86_64 
  lib64qt5gui-devel              5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5gui5                   5.0.2        1.mga3        x86_64 
  lib64qt5network-devel          5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5network5               5.0.2        1.mga3        x86_64 
  lib64qt5opengl-devel           5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5opengl5                5.0.2        1.mga3        x86_64 
  lib64qt5printsupport-devel     5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5printsupport5          5.0.2        1.mga3        x86_64 
  lib64qt5qml5                   5.0.2        1.mga3        x86_64 
  lib64qt5quick5                 5.0.2        1.mga3        x86_64 
  lib64qt5sql-devel              5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5sql5                   5.0.2        1.mga3        x86_64 
  lib64qt5test-devel             5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5test5                  5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5v8_5                   5.0.2        2.mga3        x86_64 
  lib64qt5webkit5                5.0.2        1.mga3        x86_64 
  lib64qt5webkitwidgets5         5.0.2        1.mga3        x86_64 
  lib64qt5widgets-devel          5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5widgets5               5.0.2        1.mga3        x86_64 
  lib64qt5xml-devel              5.0.2        1.mga3        x86_64  (navrhováno)
  lib64qt5xml5                   5.0.2        1.mga3        x86_64 
  lib64qtclucene5                5.0.2        1.mga3        x86_64 
  lib64qtdesigner5               5.0.2        1.mga3        x86_64 
  lib64qthelp5                   5.0.2        1.mga3        x86_64 
  lib64qtscript5                 5.0.2        1.mga3        x86_64 
  lib64xcb-icccm4                0.3.9        2.mga3        x86_64 
  lib64xcb-util-image0           0.3.9        4.mga3        x86_64 
  lib64xcb-util-renderutil0      0.3.8        3.mga3        x86_64 
  qt-creator                     2.7.0        2.mga3        x86_64 
  qtbase5-common                 5.0.2        1.mga3        x86_64 
  qtbase5-common-devel           5.0.2        1.mga3        x86_64  (navrhováno)
  qtbase5-database-plugin-sqlite 5.0.2        1.mga3        x86_64  (navrhováno)
  qttools5-assistant             5.0.2        1.mga3        x86_64  (navrhováno)
  qttools5-designer              5.0.2        1.mga3        x86_64  (navrhováno)
Navíc bude použito 187MB diskového prostoru.
Bude staženo 44MB balíčků.
Pokračovat v instalaci 43 balíčků? (A/n) n

EDIT: zdroje
« Poslední změna: Prosinec 30, 2013, 19:57:50 od Yullaw »

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #2 kdy: Prosinec 30, 2013, 19:57:55 »
do toho ru se mi moc nechce, to už radši  z qt-projekt.org vyšší verzi

máš to instalované z ofiko repa a vidíš tam to qt 5.0.2 v  nastavení kitu?

to je to co mě zajímá. vypadá to že ten balík nemá dodělané závislosti - překladač a debugger je potřeba nainstalovat samostatně - i nás gcc a gdb, bez viditelnosti verze QT mě to nepustí k otevření projektu.

jinak rozdíl mezi 4.8.2 a 5.0.2 je propastný, 5.0.2 a výš už umožňuje programovat pro Android třeba klienta k db
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #3 kdy: Prosinec 30, 2013, 20:10:08 »
qt-creator nainstalován z oficiálních repozitářů (64bit - info o SW viz. podpis). Zde máš screenshot. Pokud chceš jiný náhled, nasměruj mě přesněji.

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #4 kdy: Prosinec 30, 2013, 20:16:05 »
tady jsem byl taky. to je v pohodě
zkus ale na téhle obrazovce odkaz examples (vpravo nahoře) - měl bys tam vidět příklady programů já to mám prázdné a zkus vyrobit nový projekt jestli to půjde
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #5 kdy: Prosinec 30, 2013, 20:25:52 »
Examples - prázdné.

File → New File or Project → Aplications → Qt GUI Aplication → Choose → Next → ... Next → viz. obr.

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #6 kdy: Prosinec 30, 2013, 20:37:24 »
aha - tak se to asi rozdrbalo při instalaci odinstalaci - myslím to že nevidím verzi QT

poslední věc prosím tě mrkni do Tools -> Option -> a tady najdi verzi QT nemám to teď nainstalované  je tam sada záložek kits překladač debugger a jedna je QT - tady se nastavuje jak se to má přeložit jestli pro desktop ne bo android nebo mac atd měli by tu být vidě všechny nainstalované verze QT takže 482, 508 a jiné postni co tam uvidíš dík
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #7 kdy: Prosinec 30, 2013, 20:47:00 »
aha - tak se to asi rozdrbalo při instalaci odinstalaci - myslím to že nevidím verzi QT

poslední věc prosím tě mrkni do Tools -> Option -> a tady najdi verzi QT nemám to teď nainstalované  je tam sada záložek kits překladač debugger a jedna je QT - tady se nastavuje jak se to má přeložit jestli pro desktop ne bo android nebo mac atd měli by tu být vidě všechny nainstalované verze QT takže 482, 508 a jiné postni co tam uvidíš dík
« Poslední změna: Prosinec 30, 2013, 20:53:59 od Yullaw »

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #8 kdy: Prosinec 30, 2013, 20:54:50 »
jo tak tady je vidět nějaká zrada - v popisech má být instalováno 5.0.2 a tady je vypsáno 4.8.2

něco shnilého je ve státě dánském

fungovat to bude, ale co to vlastně v tom systému máme babo raď :D - vypadá to na odfláklý RPM balíček - nezobrazí se examples a verze QT to je velký rébus v /usr/lib64/ je QT5 složka kde jsou všechny příklady a ostaní soubory podle popisu.

každopádně dík za trpělivost, máš to ve stejném stavu jako já. zkusím ještě trochu pobádat, jestli na něco přijdu, tak to sem hodím.
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #9 kdy: Prosinec 30, 2013, 21:11:44 »
... - nezobrazí se examples...

doinstaluj balíček qt4-examples

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #10 kdy: Prosinec 30, 2013, 21:52:02 »
Změna z Qt 4.8.5 na Qt 5.0.2:
- odstranit řádek s Qt4 v záložce Qt Versions
- Add, najdi qmake v /usr/lib64/qt5/bin
- výsledek viz. screenshot

ale nezobrazí se mi Examples, i když nainstaluji balíček qtbase5-examples

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #11 kdy: Leden 01, 2014, 15:38:37 »
tak po čisté instalaci systému to naběhne v pořádku s verzí 5.0.2. Tímto se omlouvám autorovi balíčku, že jsem ho osočil, že to odflákl.

Jediné co nenabíhá jsou ty příklady, řešení jsem neobjevil a hledal jsem fest. škoda
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #12 kdy: Leden 14, 2014, 19:44:20 »
Tak toto téma ještě oživím:
na noťasu je to ve stavu, že není k vybrání žádná verze qt.
zkontroloval jsem to proti desktopu a na notasu chybí v ../qt5/bin qmake, moc a ještě další soubory.

HEURÉÉKA!!

Doplníme je tak, že nainstalujeme balíček qtbase5-common-devel který je obsahuje, pak už jde vybrat verzi QT

MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

tomyp

  • Jr. Member
  • **
  • Příspěvků: 77
  • Karma: +2/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #13 kdy: Leden 28, 2014, 20:20:18 »
Po včerejší dlouhé noci, kdy jsem řešil problém proč mi preprocesor hlásí na instrukci
#include <QMainWindow>  chybu "no such file or directory"
jsem se dobral zřejmě ke konečnému poznání co je špatně.

pro správnému fungování je potřeba mít instalované balíčky jak lib64qt5NECO, tak ib64qt5NECO-devel, protože v devel balíčcích jsou ony hlavičkové soubory tvořící QT framework viz předchozí odstavec- např qmainwindow.h - adresář /lib64/qt5/include/

teď vlastní problém - devel balíčky mají závislost na dalších balíčcích(dobral jsem se např. k jednomu co má na starosti utf8)
Pokud instalujete qt na čistou instalaci systému bez aktualizování, vše se nainstaluje ok. Při aktualizaci systému se aktualizují  balíčky požadované qt a mcc pak devel balíčky neistaluje - hlášení "balíček nelze vybrat" - proč se tady nedozvíme

konzole už je sdílnější - tam jsem objevil ten problém se závislostmi(balíček závisí na starší verzi než je instalovaná)

takže jsem tam balíčky devel narval přes kozoli natvrdo s argumentem nodeps(poslední který jsem zadal, force nefungovalo) a už všechno maká jak má.

tak myslím že to je všechno k problému, snad to pomůže někomu dalšímu.
MGA 4 64bit KDE
Smrt a daně jsou jisté, daně jistější

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 737
  • Karma: +53/-0
    • Zobrazit profil
Re:Qt - creator
« Odpověď #14 kdy: Leden 28, 2014, 20:38:16 »
Tudíž vše z tvé strany ok? Označit téma za vyřešeno?

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M