Autor Téma: Po aktualizaci kernelu nefunguje webkamera Logitec  (Přečteno 88 krát)

hank

  • Newbie
  • *
  • Příspěvků: 9
  • Karma: +2/-0
    • Zobrazit profil
Po aktualizaci kernelu nefunguje webkamera Logitec
« kdy: Prosinec 30, 2021, 22:48:13 »
Ahoj všichni,

mám webkameru Logitec Live! Cam Sync HD:

Kód: [Vybrat]
$ lsusb
Bus 002 Device 004: ID 041e:4095 Creative Technology, Ltd Live! Cam Sync HD [VF0770]

V MGA 7 nebyl problém. Po instalaci MGA 8 s release kernelem 5.10.70 fungovala OK. Ale po aktualizaci kernelu začala používat modul snd_usb_audio místo modulu uvcvideo. Takže všechny aplikace (skypeforlinux, cheese) hlásí, že video zařízení nebylo nalezeno.

Když nabootuji s původním release kernel-desktop-5.10.70, tak kamera normálně funguje.

S novými jádry (např. aktuální 5.15.11) nastává výše popsaný problém.

Kód: [Vybrat]
$ dmesg
[21334.982304] usb 2-1: new high-speed USB device number 6 using xhci_hcd
[21335.202037] usb 2-1: New USB device found, idVendor=041e, idProduct=4095, bcdDevice=20.20
[21335.202046] usb 2-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[21335.202050] usb 2-1: Product: Live! Cam Sync HD VF0770
[21335.202052] usb 2-1: Manufacturer: Creative Technology Ltd.
[21335.202054] usb 2-1: SerialNumber:


Zjistil jsem, že od verze kernelu 5.10.75 je v souboru /lib/modules/<kernel_verze>/modules.alias, uveden řádek:

Kód: [Vybrat]
alias usb:v041Ep4095d*dc*dsc*dp*ic*isc*ip*in* snd_usb_audio
Tento řádek v původním modules.alias release kernelu chybí.

Jak zajistím, aby se zaváděl pro uvedenou webkameru modul uvcvideo místo snd_usb_audio?

Díky všem za rady.




Joelp

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 544
  • Karma: +12/-0
    • Zobrazit profil
    • blog
Re:Po aktualizaci kernelu nefunguje webkamera Logitec
« Odpověď #1 kdy: Prosinec 31, 2021, 13:34:58 »
Ahoj,

zkus si modul načíst pomocí
Kód: [Vybrat]
modprobe uvcvideo.

Je to si ce na lavačku, ale rebind by ti měl pomoci: https://zedt.eu/tech/linux/restarting-usb-subsystem-centos/

Nevím jestli je to dobrý nápad, za zkoušku ale stojí onen bind řádek v
Kód: [Vybrat]
/lib/modules/zakomentovat.
cat /etc/mageia-release
Mageia release 8 (Official) for x86_64

hank

  • Newbie
  • *
  • Příspěvků: 9
  • Karma: +2/-0
    • Zobrazit profil
Re:Po aktualizaci kernelu nefunguje webkamera Logitec
« Odpověď #2 kdy: Prosinec 31, 2021, 16:19:27 »
Díky za reakci. Modul uvcvideo už zavedený je, protože mám ještě jinou webkameru (tj. mám současně připojené dvě). Ale i když nechám jen toho Logiteca, tak to nemá efekt.

To s tím unbind/bind jsem zkoušel ještě včera večer.

Tj. zjistil jsem, pod jakým číslem na usb je ta kamera a pak jsem jako root zadal:

Kód: [Vybrat]
# echo -n "2-1:1.0" > /sys/bus/usb/drivers/snd-usb-audio/unbind
a následně:

Kód: [Vybrat]
# echo -n "2-1:1.0" > /sys/bus/usb/drivers/uvcvideo/bind
Ale nějak to nepomohlo:
Kód: [Vybrat]
$ dmesg
[91758.005529] usb 2-1: Found UVC 1.00 device Live! Cam Sync HD VF0770 (041e:4095)
[91758.010855] usb 2-1: No streaming interface found for terminal 3.
[91758.011050] input: Live! Cam Sync HD VF0770: Live! as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0/input/input22
Video zřízení stále neexistuje.

Nebo to dělám špatně?

Ohledně toho module.alias -- zakomentování řádku nepomůže...

Joelp

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 544
  • Karma: +12/-0
    • Zobrazit profil
    • blog
Re:Po aktualizaci kernelu nefunguje webkamera Logitec
« Odpověď #3 kdy: Leden 01, 2022, 09:11:20 »
Co jsem tak googlil, tak je asi jediné řešení používat starý kernel, nebo si jej zkompilovat s úpravami. Těžko se ale radí, když nemám takovou kameru.

Co mě napadlo, tak zkusit
Kód: [Vybrat]
rmmod -w snd-usb-audio a zasunout kameru jestli se chytne s uvcvideo.
cat /etc/mageia-release
Mageia release 8 (Official) for x86_64

hank

  • Newbie
  • *
  • Příspěvků: 9
  • Karma: +2/-0
    • Zobrazit profil
Re:Po aktualizaci kernelu nefunguje webkamera Logitec
« Odpověď #4 kdy: Leden 01, 2022, 13:46:53 »
Tak se to nějak zázračně opravilo samo... Aniž bych něco dalšího zkoušel, tak dnes jsem kameru připojil a najednou funguje.

Kód: [Vybrat]
[16855.647988] usb 2-1: new high-speed USB device number 4 using xhci_hcd
[16855.867712] usb 2-1: New USB device found, idVendor=041e, idProduct=4095, bcdDevice=20.20
[16855.867720] usb 2-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
[16855.867724] usb 2-1: Product: Live! Cam Sync HD VF0770
[16855.867726] usb 2-1: Manufacturer: Creative Technology Ltd.
[16855.867728] usb 2-1: SerialNumber: 
[16855.873112] usb 2-1: Found UVC 1.00 device Live! Cam Sync HD VF0770 (041e:4095)
[16855.890398] input: Live! Cam Sync HD VF0770: Live! as /devices/pci0000:00/0000:00:14.0/usb2/2-1/2-1:1.0/input/

Možná jsem včera instaloval nějaké aktualizace, ale to si teď nejsem jistý...

Každopádně díky za pomoc.