Odpověď

Upozornění: do tohoto tématu bylo naposledy přispěno před 120 dny.
Zvažte prosím založení nového tématu.
Jméno:
E-mail:
Předmět:
Ikona zprávy:

Ověření:
Zadejte znaky zobrazené na obrázku
Poslechnout obrázek / Požádat o jiný obrázek

Zadejte znaky zobrazené na obrázku:
Kolik má průměrný člověk prstů na pravé ruce? (číslem):

Zkratky: stiskněte shift+alt+s pro odeslání nebo shift+alt+p pro prohlédnutí


Shrnutí tématu

Poslal: jamys601
« kdy: Květen 13, 2020, 15:29:10 »

Takže problém vyřešen a to následovně, stručný popis:
Vymazal jsem soubor /etc/modprobe.d/ath9k.conf., wifina i bez něj na novějších jádrech chodí normálně.
Vysvětlení:
Při povýšení z MGA 6 na MGA 7 problém s WIFI při suspend to RAM - adaptér QCA9565 / AR9565 - po probuzení nestabilní připojení k síti, řešil jsem dle stránek http://wiki.mageia.cz/hardware:wifi ( je zajímavé, že v MGA 6.0 - 6.1 jsem tohle řešit nemusel, byl to problém i v MGA 5.0 a 5.1 a v 7-mičce se to opět vrátilo...). Vše takto nastaveno fungovalo až do kernelu 5.1.20, kde začal haprovat Virtualbox. Takže zatím co celý systém stále fungoval normálně, tak Virtualbox od kernelu 5.2.* to už nerozchodil, proto mě to pořád mátlo a hledal jsem chyby, kde nebyly. Je to takový specifický problém a snad to třeba někomu s podobným problémem pomůže.
Poslal: jamys601
« kdy: Květen 13, 2020, 11:05:39 »

Takže pokračování v řešení problému:
Udělal jsem si čistou instalaci MGA 7.1 na externí disk, provedl auktualizace a nabootoval z něj - naistaloval Virtualbox 6.0.20 z repozitářů MGA, vč. příslušný Extension Pack k dané verzi přímo ze stránek Virtualboxu a vytvořil zde virtuální stroj s použitím konkrétně již dříve vytvořeného disku Opensuse Leap 15.1., který vykazoval ony zmíněné problémy ( mimo jiných dříve zmíněných virtuálních strojů ) a chod naprosto O.K.
Prozatímní závěr: Zřejmě bordel v mém systému, který jsem nepřeinstalovával od čisté instalace verze MGA 5.1 ( pouze povyšování systému až do současné verze 7.1 ) + natvrdo narvané balíčky programů z jiných distribucí ( např. Fedory ). Mám teď čistě referenční systém na ext. disku, takže ve volném čase mohu zkoumat...
( Jen mě stále mátlo, že vše na hlavním systému fungovalo až do kernelu 5.1.20 i s těmi neoriginálními balíčky, nyní s nejnovějším kernelem systém šlape stále jako hodinky, kromě Virtualboxu... ).
Poslal: jamys601
« kdy: Květen 11, 2020, 18:36:21 »

A výpis lspci z kernelu 5.1.20 je identický.
Poslal: jamys601
« kdy: Květen 11, 2020, 18:05:14 »

Znovu a lépe příloha lspci...
Poslal: jamys601
« kdy: Květen 11, 2020, 17:49:18 »

To vypadá na nějaký problém s grafickou kartou ovladače/nastavení Virtualboxu/...

Co používáš za ovladače? A jak máš nastavenou grafiku ve VirtualBoxu?

Podobné chování jak na Intel, tak Nvidia grafikách nepozoruji.
Na Virtualboxu jsem vyzkoušel všechny možné nastavení grafiky i paravirtualizace - momentálně na aktuálním kernelu 5.6.8 - přídavky pro hosta i Extension Pack nainstalovány, zkrátka celý "ansámbl" pro nyní aktuální Virtualbox. Stejně to bez problému funguje pouze do Kernelu 5.1.20-desktop-2.mga7. Další novější jádra se zmíněnými problémy. Zkoušel jsem odinstalovat balíčky x11-driver-video-intel a s tím i x11-driver-video-7.7-15.mga7.x86_64, vyřazen xorg.conf, leč na novějších jádrech stále se stejným výsledkem. Mně to přijde jako nestardardní komunikace mezi kernelem, grafikou a virtualboxem, nevím... přikládám výpis lspci z hostujícího PC.
Vzhledem k tomu, že jsem na Googlu a různých fórech na nic podobného nenarazil, bude asi problém někde pouze u mě, ale čert ví kde...
Takže když zkouším virtuální stroje ve Virtulboxu, musím si bootnout do kernelu 5.1.20.
Poslal: Joelp
« kdy: Květen 09, 2020, 11:12:50 »

To vypadá na nějaký problém s grafickou kartou ovladače/nastavení Virtualboxu/...

Co používáš za ovladače? A jak máš nastavenou grafiku ve VirtualBoxu?

Podobné chování jak na Intel, tak Nvidia grafikách nepozoruji.
Poslal: jamys601
« kdy: Květen 06, 2020, 12:13:05 »

Jen upřesňuji, vše výše popsané se děje pouze v hostovi, hostující systém jede bez problému dále.
Poslal: jamys601
« kdy: Květen 06, 2020, 11:44:17 »

Zdravím,
jen pro zajímavost: Od kernelu 5.2.* až do teď ( aktuálně kernel 5.6.8 ) - jedno, jestli kernel-desktop nebo server, jsou nestabilní virt. stroje ve Virtualboxu ve verzích 6.0.8 až 6.0.20 z repozitáře MGA. Systém plně aktuální ( ke dni 06.05. 2020). Všechny virtuální stroje ( Opensuse, Fedora, Ubuntu atd.) končí pádem grafického prostředí, nikoliv však celého systému, ale i tak je práce ve Virtualboxu nepoužitelná. Padá většina aplikací, aktualizace systému atd. - většinou jako SIGSEGV error 4 až 6, záleží na aplikaci a virtuálním stroji. Ve Virtualboxu mohu nastavovat různé kombinace nastavení jak chci ( počet procesorů, způsob virtualizace atd., vždy se stejnými výsledky ). Nepomohla ani instalace Virtualboxu přímo z jejich stránek, vč. aktuálního VB 6.1.6. Poslední jádro, kde VB normálně funguje je kernel 5.1.20-desktop-2.mga7. Mám VB pouze pro samostudium různých systémů, nikoliv pro ostrý provoz, ale i tak mě zajímá, jestli jste se s tímto někdo nesetkal a jak to případně řešit ( podotýkám, že jinak s chodem plně aktualizovaného systému problém nemám ). Hledal jsem přes Google až po různá fóra, řešení jsem nenašel nebo nepochopil...
( Je to ke stroji DELL Inspiron, co mám v popisu ).
Díky za případnou reakci.