Autor Téma: Špatně reagující PowerManagement  (Přečteno 1924 krát)

Pavel Vybíral

  • Full Member
  • ***
  • Příspěvků: 209
  • Karma: +10/-1
    • Zobrazit profil
Špatně reagující PowerManagement
« kdy: Listopad 05, 2014, 18:56:21 »
Zdravím.
Dnešním dnem (5. 11. 2014) se mi na mém notebooku Lenovo G580 se systémem Mageia 4 (64bit) začal projevovat poměrně zvláštní problém s Power Managementem. Když spustím notebook, nabootuje mi systém a přihlásím se k účtu a vypojím notebook ze zdroje napájení, standardně by se měl snížit jas obrazovky ze 100% na 30% a applet v systémové části panelu KDE by měl ukazovat počet procent zbývající energie v baterii. K tomu však dojde buď cca. po půl minutě nebo k tomu ve většině případů nedojde vůbec. Nastavení PowerManagementu v KDE (Pravým tlačítkem na applet v systémové části panelu->Nastavení "Monitor baterie") se tváří, že je vše v pořádku, vše jde nastavit. Démon upower nevykazuje žádné problémy (alespoň ne podle příkazu systemctl status upower, jehož výstup je následující):
Kód: [Vybrat]
[root@Pavel-Notebook pavel]# systemctl status upower -l
upower.service - Daemon for power management
   Loaded: loaded (/usr/lib/systemd/system/upower.service; enabled)
   Active: active (running) since St 2014-11-05 18:37:44 CET; 9min ago
     Docs: man:upowerd(8)
 Main PID: 2291 (upowerd)
   CGroup: /system.slice/upower.service
           └─2291 /usr/libexec/upowerd

lis 05 18:37:44 Pavel-Notebook systemd[1]: Started Daemon for power management.
Kromě toho se také po kliknutí na "Restartovat počítač" v KDE počítač nerestartuje, ale vypne, což není zas až takový problém.

Poměrně zajímavé je, že jakmile notebook uspím a znovu probudím, vše se chová úplně normálně, veškeré problémy s PowerManagementem i restartováním počítače zmizí. V souvislosti s tím se také mírně změní výpis příkazu systemctl status upower:
Kód: [Vybrat]
[root@Pavel-Notebook pavel]# systemctl status upower -l
upower.service - Daemon for power management
   Loaded: loaded (/usr/lib/systemd/system/upower.service; enabled)
   Active: active (running) since St 2014-11-05 18:37:44 CET; 9min ago
     Docs: man:upowerd(8)
 Main PID: 2291 (upowerd)
   CGroup: /system.slice/upower.service
           └─2291 /usr/libexec/upowerd

lis 05 18:37:44 Pavel-Notebook systemd[1]: Starting Daemon for power management...
lis 05 18:37:44 Pavel-Notebook systemd[1]: Started Daemon for power management.
lis 05 18:39:03 Pavel-Notebook upowerd[2291]: (upowerd:2291): UPower-Linux-WARNING **: no valid voltage value found for device /sys/devices/LNXSYSTM:00/device:00/PNP0A08:00/device:02/PNP0C0A:00/power_supply/BAT1, assuming 10V

Zkoušel jsem přepnout na prostředí KDE, MATE a GNOME, chyba se projevuje ve všech třech. Poté jsem zkusil nabootovat live distribuci (mám dojem, že je to Fedora) s GNOME 3.14, kde také nebyl žádný problém. Chyba je tedy pravděpodobně na straně systému.

Nevím, proč se systém začal takhle chovat. Jsem si jistý, že jsem do ničeho jako je PowerManagement nedrbal a mám za to, že se ani nic takového neaktualizovalo.

Už opravdu nevím co s tím. Předem děkuji za rady. :)
Notebook Lenovo IdeaPad G580
Intel Core i7 @ 2.90GHz, 6GB RAM, Intel HD 4000 & nVidia GeForce GT635M
Mageia 4 64 Bit (kernel-desktop-3.14.32-1.mga4); KDE 4.12.5

Pavel Vybíral

  • Full Member
  • ***
  • Příspěvků: 209
  • Karma: +10/-1
    • Zobrazit profil
Re:Špatně reagující PowerManagement
« Odpověď #1 kdy: Listopad 05, 2014, 19:25:26 »
Ještě doplním:
1) Teď jsem vypozoroval, že chyba s restartem není pravidelná, nastane jen někdy.
2) Pro upřesnění: S PowerManagementem je chyba prakticky jediná: Nedokáže správně indikovat odpojení/připojení adaptéru. Vše ostatní se zdá být  funkční.
Notebook Lenovo IdeaPad G580
Intel Core i7 @ 2.90GHz, 6GB RAM, Intel HD 4000 & nVidia GeForce GT635M
Mageia 4 64 Bit (kernel-desktop-3.14.32-1.mga4); KDE 4.12.5

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:Špatně reagující PowerManagement
« Odpověď #2 kdy: Listopad 06, 2014, 07:15:26 »
Zkus ACPI/APIC (nastavuje se to v MCC > Boot > Setup Boot > Advanced) a trochu si s tim pohrat. Mohlo dojit napr. k aktualizaci kernelu.
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

Pavel Vybíral

  • Full Member
  • ***
  • Příspěvků: 209
  • Karma: +10/-1
    • Zobrazit profil
Re:Špatně reagující PowerManagement
« Odpověď #3 kdy: Listopad 06, 2014, 15:54:57 »
Ahoj.
Děkuju za radu. Bohužel, nebylo to řešením. Zkusil jsem kombinace vypnutého a zapnutého ACPI, APIC a Lokální APIC, ale problém to nevyřešilo.
Nicméně přikládám další informaci.  Když mám adaptér zapojený a zadám příkaz acpi -V, dostanu výstup:
Kód: [Vybrat]
[pavel@Pavel-Notebook ~]$ acpi -V
Battery 0: Charging, 96%, 00:00:08 until charged
Battery 0: design capacity 3304 mAh, last full capacity 3302 mAh = 99%
Adapter 0: on-line
Thermal 0: ok, 50.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 127.0 degrees C
Thermal 0: trip point 1 switches to mode hot at temperature 127.0 degrees C
Cooling 0: x86_pkg_temp no state information available
Cooling 1: intel_powerclamp no state information available
Cooling 2: Processor 0 of 10
Cooling 3: Processor 0 of 10
Cooling 4: Processor 0 of 10
Cooling 5: Processor 0 of 10
Cooling 6: LCD 0 of 100
Cooling 7: LCD 0 of 100

Když udělám to samé s vypojeným adaptérem (příkaz zadám hned po vypojení), dostanu:
Kód: [Vybrat]
[pavel@Pavel-Notebook ~]$ acpi -V
Battery 0: Discharging, 96%, 00:03:36 remaining
Battery 0: design capacity 3304 mAh, last full capacity 3302 mAh = 99%
Adapter 0: off-line
Thermal 0: ok, 51.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 127.0 degrees C
Thermal 0: trip point 1 switches to mode hot at temperature 127.0 degrees C
Cooling 0: x86_pkg_temp no state information available
Cooling 1: intel_powerclamp no state information available
Cooling 2: Processor 0 of 10
Cooling 3: Processor 0 of 10
Cooling 4: Processor 0 of 10
Cooling 5: Processor 0 of 10
Cooling 6: LCD 0 of 100
Cooling 7: LCD 0 of 100

Takže chyba je možná v démonu upower. Jak je vidět, ACPI vypojení adaptéru zaregistruje a na základě toho se taky zachová. Dokonce jsou správně měněny i hodnoty v souboru /sys/class/power_supply/ACAD/online, kde je buď 1 (zapojený adaptér) nebo 0 (vypojený adaptér). Démona upower jsem sice zkusil reinstalovat (příkazem urpmi --replacepkgs upower), ale bez výsledku. V jeho konfiguračním souboru (/etc/UPower/UPower.conf) je zapsáno, že by měl reagovat na vypojení/zapojení adaptéru, viz. řádek:
Kód: [Vybrat]
RunPowersaveCommand=true
Víc jsem bohužel zatím nezjistil...
Notebook Lenovo IdeaPad G580
Intel Core i7 @ 2.90GHz, 6GB RAM, Intel HD 4000 & nVidia GeForce GT635M
Mageia 4 64 Bit (kernel-desktop-3.14.32-1.mga4); KDE 4.12.5

Pavel Vybíral

  • Full Member
  • ***
  • Příspěvků: 209
  • Karma: +10/-1
    • Zobrazit profil
Re:Špatně reagující PowerManagement
« Odpověď #4 kdy: Listopad 09, 2014, 11:22:30 »
Bohužel, nepodařilo se najít řešení problému a já jsem prakticky neměl žádné vodítko, takže jsem problém vyřešil reinstalací. Děkuji všem za pomoc. :)
Notebook Lenovo IdeaPad G580
Intel Core i7 @ 2.90GHz, 6GB RAM, Intel HD 4000 & nVidia GeForce GT635M
Mageia 4 64 Bit (kernel-desktop-3.14.32-1.mga4); KDE 4.12.5