Autor Téma: [Vyřešeno]LibreCad - padá  (Přečteno 5154 krát)

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
[Vyřešeno]LibreCad - padá
« kdy: Květen 31, 2014, 13:57:37 »
Kreslil jsem, postupem doby však program čím dál častěji spadnul. Teď už se nedá použít. Spadne vždy s touto hláškou. Verze 2.0.0 rc1
 
Citace
[tom@MGA3_NTBlenovo ~]$ librecad
Check failed in file /usr/include/boost/numeric/ublas/functional.hpp at line 1370:
i < size_i
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'boost::numeric::ublas::bad_index'
  what():  bad index
Neúspěšně ukončen (SIGABRT)

Řešili to tady,
Citace
http://sourceforge.net/p/librecad/bugs/431/
závěr mě však nějak minul. Netušítě někdo?

EDIT:[Vyřešeno]
« Poslední změna: Červen 19, 2014, 17:14:53 od Yullaw »
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #1 kdy: Červen 04, 2014, 19:13:03 »
Zde (http://forum.mageia.cz/index.php?topic=672.0) jsi vyřešil jeden problém a nakonec se ti objeví problém další  :-\

Kreslil jsem, postupem doby však program čím dál častěji spadnul. Teď už se nedá použít. Spadne vždy s touto hláškou. Verze 2.0.0 rc1

Kód: [Vybrat]
[tom@MGA3_NTBlenovo ~]$ librecad
Check failed in file /usr/include/boost/numeric/ublas/functional.hpp at line 1370:
i < size_i
Qt has caught an exception thrown from an event handler. Throwing
exceptions from an event handler is not supported in Qt. You must
reimplement QApplication::notify() and catch all exceptions there.

terminate called after throwing an instance of 'boost::numeric::ublas::bad_index'
  what():  bad index
Neúspěšně ukončen (SIGABRT)

Řešili to tady,
Kód: [Vybrat]
http://sourceforge.net/p/librecad/bugs/431/
závěr mě však nějak minul. Netušítě někdo?

Nahlášený bug byl uzavřen opravou v nové verzi programu. Bohužel v MGA4 oficiálních/neoficiálních není dostupná novější veze. Možná bude aktualizace do doby vydání MGA5.

@Peťoš: - další požadavek do tvého repozitáře

Nicméně, nejnovější verzi 2.0.4 mohu zkompilovat a program spustit v MGA4 64bit.

Odinstalace LibreCAD a dalších závislostí pod rootem:
Kód: [Vybrat]
# urpme librecad

Instalace potřebných balíčků pod rootem:
Kód: [Vybrat]
# urpmi git gcc make qt4-devel boost-devel muParser-devel

Pod uživatelem:
Kód: [Vybrat]
$ cd ~/Stažené
$ git clone https://github.com/LibreCAD/LibreCAD.git
$ cd LibreCAD
$ qmake librecad.pro
$ make
$ cd unix
$ ./librecad

Otestuj, pokud bude plně funkční (možná budou chybět pluginy(?)), tak si vytvoř odkaz na plochu.

Pokud nebude funčkní, bude nespokojenost, odstraň vytvořenou složku LibreCad v ~/Stažené.

Snad to pofrčí :)

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
Re:LibreCad - padá
« Odpověď #2 kdy: Červen 05, 2014, 18:21:12 »
...tak zatim jsem moc daleko nedošel, můj bash nezná příkaz git. Co s tím?
Díky 
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #3 kdy: Červen 05, 2014, 18:55:46 »
Použil jsi příkaz pod rootem (nainstaloval jsi)?
Kód: [Vybrat]
urpmi git gcc make qt4-devel boost-devel muParser-devel

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
Re:LibreCad - padá
« Odpověď #4 kdy: Červen 05, 2014, 20:54:35 »
Ano, použil, instalace však neproběhla v pořádku. Toho jsem si před tím nevšiml.


Kód: [Vybrat]
[root@MGA3DuoCore home]# urpmi git gcc make qt4-devel boost-devel muParser-devel
Balíčky make-4.0-2.mga4.x86_64, lib64qt4-devel-4.8.6-1.mga4.x86_64, gcc-4.8.2-3.mga4.x86_64 jsou již nainstalovány
Označuji make jako ručně instalovaný, nebude pak automaticky považován za sirotka
Označuji lib64qt4-devel jako ručně instalovaný, nebude pak automaticky považován za sirotka
Označuji gcc jako ručně instalovaný, nebude pak automaticky považován za sirotka
writing /var/lib/rpm/installed-through-deps.list
Aby byly splněny závislosti, budou nainstalovány následující balíčky:
  Balíček                        Verze        Vydání        Arch.   
(zdroj "Core Release")
  cvs                            1.12.13      22.mga4       x86_64  (navrhováno)
  cvsps                          2.2b1        4.mga4        x86_64  (navrhováno)
  git                            1.8.4.5      1.mga4        x86_64 
  git-arch                       1.8.4.5      1.mga4        x86_64  (navrhováno)
  git-core                       1.8.4.5      1.mga4        x86_64 
  git-core-oldies                1.8.4.5      1.mga4        x86_64  (navrhováno)
  git-cvs                        1.8.4.5      1.mga4        x86_64  (navrhováno)
  git-email                      1.8.4.5      1.mga4        x86_64 
  git-prompt                     1.8.4.5      1.mga4        x86_64  (navrhováno)
  git-svn                        1.8.4.5      1.mga4        x86_64 
  gitk                           1.8.4.5      1.mga4        x86_64  (navrhováno)
  lib64boost-devel               1.54.0       8.mga4        x86_64 
  lib64boost_atomic1.54.0        1.54.0       8.mga4        x86_64 
  lib64boost_context1.54.0       1.54.0       8.mga4        x86_64 
  lib64boost_graph1.54.0         1.54.0       8.mga4        x86_64 
  lib64boost_iostreams1.54.0     1.54.0       8.mga4        x86_64 
  lib64boost_log1.54.0           1.54.0       8.mga4        x86_64 
  lib64boost_math1.54.0          1.54.0       8.mga4        x86_64 
  lib64boost_prg_exec_monitor1.> 1.54.0       8.mga4        x86_64 
  lib64boost_python1.54.0        1.54.0       8.mga4        x86_64 
  lib64boost_random1.54.0        1.54.0       8.mga4        x86_64 
  lib64boost_serialization1.54.0 1.54.0       8.mga4        x86_64 
  lib64boost_timer1.54.0         1.54.0       8.mga4        x86_64 
  lib64boost_unit_test_framewor> 1.54.0       8.mga4        x86_64 
  lib64boost_wave1.54.0          1.54.0       8.mga4        x86_64 
  lib64boost_wserialization1.54> 1.54.0       8.mga4        x86_64 
  lib64icu-devel                 52.1         2.mga4        x86_64 
  lib64serf1                     1.3.2        2.mga4        x86_64 
  muParser                       1.34         4.mga4        x86_64 
  muParser-devel                 1.34         4.mga4        x86_64 
  perl-Authen-SASL               2.160.0      3.mga4        noarch  (navrhováno)
  perl-Error                     0.170.210    2.mga4        noarch 
  perl-Git                       1.8.4.5      1.mga4        x86_64 
  perl-YAML                      0.840.0      3.mga4        noarch 
(zdroj "Core Updates")
  lib64python-devel              2.7.6        1.1.mga4      x86_64 
  lib64svn0                      1.8.8        1.mga4        x86_64 
  perl-SVN                       1.8.8        1.mga4        x86_64 
  subversion                     1.8.8        1.mga4        x86_64 
Navíc bude použito 174MB diskového prostoru.
Bude staženo 22MB balíčků.
Pokračovat v instalaci 38 balíčků? (A/n) A


    http://mageia.supp.name/distrib/4/x86_64/media/core/release/perl-Error-0.170.210-2.mga4.noarch.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_unit_test_framework1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/perl-YAML-0.840.0-3.mga4.noarch.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64serf1-1.3.2-2.mga4.x86_64.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_python1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/updates/subversion-1.8.8-1.mga4.x86_64.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/updates/lib64svn0-1.8.8-1.mga4.x86_64.rpm         
    http://mageia.supp.name/distrib/4/x86_64/media/core/updates/perl-SVN-1.8.8-1.mga4.x86_64.rpm         
instaluji lib64serf1-1.3.2-2.mga4.x86_64.rpm lib64boost_python1.54.0-1.54.0-8.mga4.x86_64.rpm subversion-1.8.8-1.mga4.x86_64.rpm lib64svn0-1.8.8-1.mga4.x86_64.rpm perl-SVN-1.8.8-1.mga4.x86_64.rpm perl-Error-0.170.210-2.mga4.noarch.rpm lib64boost_unit_test_framework1.54.0-1.54.0-8.mga4.x86_64.rpm perl-YAML-0.840.0-3.mga4.noarch.rpm z /var/cache/urpmi/rpms
Připravuji...                    ########################################################################
     1/38: lib64serf1            ########################################################################
     2/38: lib64svn0             ########################################################################
     3/38: subversion            ########################################################################
     4/38: perl-SVN              ########################################################################
     5/38: perl-YAML             ########################################################################
     6/38: lib64boost_unit_test_framework1.54.0
                                 ########################################################################
     7/38: perl-Error            ########################################################################
     8/38: lib64boost_python1.54.0
                                 ########################################################################


    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-prompt-1.8.4.5-1.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_serialization1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_wserialization1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-svn-1.8.4.5-1.mga4.x86_64.rpm         
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/perl-Git-1.8.4.5-1.mga4.x86_64.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-cvs-1.8.4.5-1.mga4.x86_64.rpm         
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-core-1.8.4.5-1.mga4.x86_64.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/muParser-1.34-4.mga4.x86_64.rpm           
instaluji lib64boost_serialization1.54.0-1.54.0-8.mga4.x86_64.rpm git-prompt-1.8.4.5-1.mga4.x86_64.rpm lib64boost_wserialization1.54.0-1.54.0-8.mga4.x86_64.rpm git-svn-1.8.4.5-1.mga4.x86_64.rpm perl-Git-1.8.4.5-1.mga4.x86_64.rpm git-core-1.8.4.5-1.mga4.x86_64.rpm git-cvs-1.8.4.5-1.mga4.x86_64.rpm muParser-1.34-4.mga4.x86_64.rpm z /var/cache/urpmi/rpms
Připravuji...                    ########################################################################


    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-email-1.8.4.5-1.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/gitk-1.8.4.5-1.mga4.x86_64.rpm           
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-1.8.4.5-1.mga4.x86_64.rpm             
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_context1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_log1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_atomic1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-arch-1.8.4.5-1.mga4.x86_64.rpm       
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_iostreams1.54.0-1.54.0-8.mga4.x86_64.rpm
instaluji lib64boost_iostreams1.54.0-1.54.0-8.mga4.x86_64.rpm lib64boost_atomic1.54.0-1.54.0-8.mga4.x86_64.rpm git-arch-1.8.4.5-1.mga4.x86_64.rpm git-1.8.4.5-1.mga4.x86_64.rpm gitk-1.8.4.5-1.mga4.x86_64.rpm git-email-1.8.4.5-1.mga4.x86_64.rpm lib64boost_log1.54.0-1.54.0-8.mga4.x86_64.rpm lib64boost_context1.54.0-1.54.0-8.mga4.x86_64.rpm z /var/cache/urpmi/rpms


    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_timer1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/muParser-devel-1.34-4.mga4.x86_64.rpm     
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/cvs-1.12.13-22.mga4.x86_64.rpm           
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_random1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_math1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_prg_exec_monitor1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/git-core-oldies-1.8.4.5-1.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/perl-Authen-SASL-2.160.0-3.mga4.noarch.rpm
instaluji git-core-oldies-1.8.4.5-1.mga4.x86_64.rpm lib64boost_math1.54.0-1.54.0-8.mga4.x86_64.rpm lib64boost_prg_exec_monitor1.54.0-1.54.0-8.mga4.x86_64.rpm perl-Authen-SASL-2.160.0-3.mga4.noarch.rpm lib64boost_random1.54.0-1.54.0-8.mga4.x86_64.rpm cvs-1.12.13-22.mga4.x86_64.rpm muParser-devel-1.34-4.mga4.x86_64.rpm lib64boost_timer1.54.0-1.54.0-8.mga4.x86_64.rpm z /var/cache/urpmi/rpms


    http://mageia.supp.name/distrib/4/x86_64/media/core/release/cvsps-2.2b1-4.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64icu-devel-52.1-2.mga4.x86_64.rpm     
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_graph1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost-devel-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/release/lib64boost_wave1.54.0-1.54.0-8.mga4.x86_64.rpm
    http://mageia.supp.name/distrib/4/x86_64/media/core/updates/lib64python-devel-2.7.6-1.1.mga4.x86_64.rpm
instaluji lib64icu-devel-52.1-2.mga4.x86_64.rpm cvsps-2.2b1-4.mga4.x86_64.rpm lib64boost_wave1.54.0-1.54.0-8.mga4.x86_64.rpm lib64boost-devel-1.54.0-8.mga4.x86_64.rpm lib64python-devel-2.7.6-1.1.mga4.x86_64.rpm lib64boost_graph1.54.0-1.54.0-8.mga4.x86_64.rpm z /var/cache/urpmi/rpms
Instalace selhala:      soubor /usr/lib64/libmuparser.so.0.0.0 z instalace muParser-1.34-4.mga4.x86_64 koliduje se souborem z balíčku lib64muparser0-1:1.32-4.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-arch-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5 je potřeba pro git-1:1.8.4.5-1.mga4.x86_64
        git-svn = 1:1.8.4.5 je potřeba pro git-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5 je potřeba pro gitk-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-email-1:1.8.4.5-1.mga4.x86_64
        perl(Git) je potřeba pro git-email-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-core-oldies-1:1.8.4.5-1.mga4.x86_64
        muParser = 1.34-4.mga4 je potřeba pro muParser-devel-1.34-4.mga4.x86_64
        cvs je potřeba pro cvsps-2.2b1-4.mga4.x86_64
        lib64boost_atomic1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_iostreams1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_log1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_math1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_prg_exec_monitor1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_random1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_serialization1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_timer1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_wserialization1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_context1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
[root@MGA3DuoCore home]# exit


Zdá se že mám v balíčcích  nějakej zmatek
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #5 kdy: Červen 05, 2014, 21:12:54 »
Ano, použil, instalace však neproběhla v pořádku. Toho jsem si před tím nevšiml.


Kód: [Vybrat]
[root@MGA3DuoCore home]# urpmi git gcc make qt4-devel boost-devel muParser-devel
...
Instalace selhala:      soubor /usr/lib64/libmuparser.so.0.0.0 z instalace muParser-1.34-4.mga4.x86_64 koliduje se souborem z balíčku lib64muparser0-1:1.32-4.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-arch-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5 je potřeba pro git-1:1.8.4.5-1.mga4.x86_64
        git-svn = 1:1.8.4.5 je potřeba pro git-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5 je potřeba pro gitk-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-email-1:1.8.4.5-1.mga4.x86_64
        perl(Git) je potřeba pro git-email-1:1.8.4.5-1.mga4.x86_64
        git-core = 1:1.8.4.5-1.mga4 je potřeba pro git-core-oldies-1:1.8.4.5-1.mga4.x86_64
        muParser = 1.34-4.mga4 je potřeba pro muParser-devel-1.34-4.mga4.x86_64
        cvs je potřeba pro cvsps-2.2b1-4.mga4.x86_64
        lib64boost_atomic1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_iostreams1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_log1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_math1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_prg_exec_monitor1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_random1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_serialization1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_timer1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_wserialization1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
        lib64boost_context1.54.0 = 1.54.0-8.mga4 je potřeba pro lib64boost-devel-1.54.0-8.mga4.x86_64
[root@MGA3DuoCore home]# exit


Zdá se že mám v balíčcích  nějakej zmatek

Ano, protože jsi neodinstaloval balíček librecad, který pak i odinstaluje libmuparser. Jak se jich zbavíš odinstalací, pak je možné opět použít příkaz k instalaci požadovaných balíčků. Musíme totiž nainstalovat jinou verzi libmuparser.

Takže, jak odinstaluješ, použij opět:
Kód: [Vybrat]
urpmi git gcc make qt4-devel boost-devel muParser-devel

i když některé požadované balíčky máš nainstalované...

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
Re:LibreCad - padá
« Odpověď #6 kdy: Červen 05, 2014, 21:45:36 »
Ach jo, asi už vim co jsem pokazil. Samozřejmě jsem nejdřív použil urpme librecad. To proběhlo v poho. Pak jsem postupoval dle tvých rad. Předpokládaný výsledek ale nenastal, viz popis výše. Chyba pramení asi z toho, že jsem bohužel před časem, v době kdy jsem měl problém s pády Librecadu, zkusil tento odinstalovat a stáhnul jsem si novější RPM z netu. Ten jsem nacpal do pc. Bohužel ale nefungoval, odebrat se mi ho nepovedlo, tak jsem použil MCC, jednoduše znova  nainstaloval Librecad z repozitářů. Ten kupodivu zase fungoval, bohužel ale padá stejně jako dřív. Asi jsem systému zavařil, a teď se nemám kam hnout. 
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #7 kdy: Červen 07, 2014, 19:32:56 »
  • Tak, LibreCAD 2.0.4 byl zkompilován a nyní je průběh testování uživatelem fantomorous.
    Ještě jsme museli provést 2 věci: - doinstalovat gcc-c++ a smazat zdrojovou složku a opět stáhnout LibreCAD...
  • Další věc. Poslal jsem bug report do bugzille s požadavkem na update: https://bugs.mageia.org/show_bug.cgi?id=13486

    Nečekal jsem tak rychlou reakci a už nyní máme novou verzi LibreCad 2.0.0 (namísto 2.0.0 RC1) ve zdrojích Core Updates Testing ! :) Ano, sice to není hned verze 2.0.4, protože tomu může bránit politika aktualizací.

    @fantomorous: nainstaluj LibreCAD 2.0.0 ze zdrojů a otestuj. Čekají na odpověď, zda je problém vyřešen...

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:LibreCad - padá
« Odpověď #8 kdy: Červen 09, 2014, 11:17:22 »
Snazim se to zbuildit (2.0.4). Mame ted dost prace doma na baraku (uz 3 mesice prestavuji spodni patro), ale uz se snad blizime do finale. Dalsi info na http://petos.cz/2014/mageia-4-a-muj-repozitar
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #9 kdy: Červen 10, 2014, 17:21:22 »
Snazim se to zbuildit (2.0.4). Mame ted dost prace doma na baraku (uz 3 mesice prestavuji spodni patro), ale uz se snad blizime do finale. Dalsi info na http://petos.cz/2014/mageia-4-a-muj-repozitar

Z důvodu rozšířených problémů byly příspěvky přesunuty do: http://forum.mageia.cz/index.php?topic=679.0

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
Re:LibreCad - padá
« Odpověď #10 kdy: Červen 16, 2014, 14:27:55 »
Tak zatím po dalším testování zkompilovaný  LibreCAD 2.0.4 v MGA4 32 bitů  funguje bez problémů. Podobně i LibreCAD 2.0.0 z Core Update Testing repozitáře v MGA4 64bit funguje stabilně.
Díky
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:LibreCad - padá
« Odpověď #11 kdy: Červen 16, 2014, 19:19:21 »
Díky za test a potvrzení funkčnosti :) V bugzille potvrzeno, žádost balíčku do Core Updates podána. Jakmile bude update protlačen/vyřešen, ozvu se...

add: Můžeš potvrdit funkčnost i v MGA4 32bit? Ze zdrojů Core Update Testing verzi LibreCAD 2.0.0 ? Potřebují potvrzení...

EDIT: add
« Poslední změna: Červen 16, 2014, 19:28:27 od Yullaw »

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:[Vyřešeno]LibreCad - padá
« Odpověď #12 kdy: Červen 19, 2014, 17:14:14 »
Dnes vydána aktualizace LibreCAD 2.0.0 v Core Updates, která napravuje výše popsaný problém.
http://advisories.mageia.org/MGAA-2014-0128.html

Téma označuji za vyřešené.

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

fantomorous

  • Full Member
  • ***
  • Příspěvků: 197
  • Karma: +3/-0
    • Zobrazit profil
    • digitemp
Re:[Vyřešeno]LibreCad - padá
« Odpověď #13 kdy: Červen 20, 2014, 09:02:13 »
Díky, dobrá práce...
NtB:Lenovo ThinkPad Edge E530 3259-AMG, Mageia 5, 64 bit, KDE 4.14.5,
Desktop: DualCore E8400 3GHz, 4GB RAM, GK Nvidia GF 8500GT 256MB 128bit, Mageia 4, 64 bit, KDE 4.12.5