Autor Téma: [Vyřešeno]HP PSC 1210 all-in-one  (Přečteno 4886 krát)

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
[Vyřešeno]HP PSC 1210 all-in-one
« kdy: Květen 04, 2014, 10:34:40 »
Zdravím, mám menší potíže s tiskem ve foto kvalitě, po zadání tohoto nastavení tiskne černobíle a obrázek je roztažený. V mandrivě tento problém mebyl, v mageia je. Netuším, co s tím, díky za radu.


EDIT:[Vyřešeno]
« Poslední změna: Květen 18, 2014, 14:49:33 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #1 kdy: Květen 04, 2014, 12:57:33 »
Verze HPLIP a CUPS?
Kód: [Vybrat]
# rpm -qa|grep hplip && rpm -qa|grep cups

Mrkni i na nastavení - záložka Image Printing, kdyžtak přihoď screenshot:
Kód: [Vybrat]
# hp-printsettings

Můžeš vyzkoušet hp-check, hp-doctor, atd. (napiš hp+ stiskni <Tab>)

Raději porovnej s nastavením přes MCCHardware Nastavit tiskárny, tiskové fronty... → pravý klik na svoji tiskárnu → Vlastnosti
« Poslední změna: Květen 04, 2014, 13:08:49 od Yullaw »

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #2 kdy: Květen 04, 2014, 18:41:08 »
ad1:
Kód: [Vybrat]
# rpm -qa|grep hplip && rpm -qa|grep cups
hplip-model-data-3.13.9-4.mga4
hplip-3.13.9-4.mga4
hplip-hpijs-3.13.9-4.mga4
hplip-hpijs-ppds-3.13.9-4.mga4
hplip-gui-3.13.9-4.mga4
python-cups-1.9.66-1.mga4
lib64cups2-1.7.0-7.1.mga4
cups-common-1.7.0-7.1.mga4
cups-1.7.0-7.1.mga4
cups-filesystem-1.7.0-7.1.mga4
cups-drivers-foo2zjs-0.0-0.20121012.3.mga4
gutenprint-cups-5.2.9-5.mga4
lib64cups-filters1-1.0.41-3.4.mga4
cups-filters-1.0.41-3.4.mga4

ad2:
Kód: [Vybrat]
HP Linux Imaging and Printing System (ver. 3.13.9)
Printer Settings Utility ver. 1.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error:  No printers or faxes found.  Please setup a printer or fax and try again.

Po zadání hp-check:
Kód: [Vybrat]
[lojza@localhost ~]$ hp-check
Saving output in log file: /home/lojza/hp-check.log

HP Linux Imaging and Printing System (ver. 3.13.9)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies are installed to successfully compile HPLIP.     
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball has the proper dependencies installed to successfully   
run.                                                                                                                                                                                                               
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and run-time dependencies).                                                         

Check types:                                                                                                                                                                                                       
a. EXTERNALDEP - External Dependencies                                                                                                                                                                             
b. GENERALDEP - General Dependencies (required both at compile and run time)                                                                                                                                       
c. COMPILEDEP - Compile time Dependencies                                                                                                                                                                         
d. [All are run-time checks]                                                                                                                                                                                       
PYEXT SCANCONF QUEUES PERMISSION                                                                                                                                                                                   

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: mageia distro is not found in AUTH_TYPES
|Gtk-Message: Failed to load module "canberra-gtk-module"
\Gtk-Message: Failed to load module "canberra-gtk-module"
warning: unknown-0.0 version is not supported. Using unknown-0 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 3.12.13-desktop-2.mga4 #1 SMP Sat Feb 22 23:45:28 UTC 2014 GNU/Linux
 Host: localhost
 Proc: 3.12.13-desktop-2.mga4 #1 SMP Sat Feb 22 23:45:28 UTC 2014 GNU/Linux
 Distribution: unknown 0.0
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.13.9
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for unknown distro  0.0 version

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.13.9

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.13.9
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp
bin=/usr/bin

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.13.9
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
lite-build=no
udev-acl-rules=yes
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:


Current contents of '~/.hplip/hplip.conf' file:
[settings]
systray_visible = 1
systray_messages = 0

[last_used]
device_uri =
printer_name =
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 30
enable = false
type = 1

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[upgrade]
notify_upgrade = true
last_upgraded_time = 1399191464.79682
pending_upgrade_time = 0

[installation]
date_time = 4.5.2014 18:38:02
version = 3.13.9


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

--------------------------
|  External Dependencies |
--------------------------

 policykit            Admin-Policy-framework    OPTIONAL        -               0.112           OK         -
 gs                   Ghostscript               REQUIRED        7.05            9.10            OK         -
 network              Network-wget              OPTIONAL        -               1.14            OK         -
 scanimage            Shell-Scanning            OPTIONAL        1.0             1.0.24          OK         -
 avahi-utils          avahi-utils               OPTIONAL        -               0.6.31          OK         -
 error: dbus          DBus                      REQUIRED        -               1.6.18          MISSING    'DBUS may not be installed or not running'
 error: cups          CUPS                      REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
Gtk-Message: Failed to load module "canberra-gtk-module"
Gtk-Message: Failed to load module "canberra-gtk-module"
 xsane                SANE-GUI                  OPTIONAL        0.9             0.998           OK         -

-------------------------
|  General Dependencies |
-------------------------

 reportlab            Python-PDF-Lib            OPTIONAL        2.0             2.7             OK         -
 error: libcrypto     OpenSSL-Crypto-Lib        REQUIRED        -               1.0.1           MISSING    'libcrypto needs to be installed'
 pil                  Python-Image-Lib          OPTIONAL        -               1.1.7           OK         -
 pyqt4-dbus           PyQt4-DBUS                REQUIRED        4.0             4.10.3          OK         -
 error: libjpeg       JPEG-Lib                  REQUIRED        -               -               MISSING    'libjpeg needs to be installed'
 libpthread           POSIX-Threads-Lib         REQUIRED        -               2.18            OK         -
 python-dbus          Python-DBUS               REQUIRED        0.80.0          1.2.0           OK         -
 error: python-devel  Python-SDK                REQUIRED        2.2             2.7.6           MISSING    'python-devel needs to be installed'
 pyqt4                Python-Qt4                REQUIRED        4.0             4.10.3          OK         -
 error: cups-devel    CUPS-SDK                  REQUIRED        -               -               MISSING    'cups-devel needs to be installed'
 error: sane-devel    SANE-SDK                  REQUIRED        -               -               MISSING    'sane-devel needs to be installed'
 error: libusb        USB-Lib                   REQUIRED        -               1.0             MISSING    'libusb needs to be installed'
 sane                 Scan-Lib                  REQUIRED        -               -               OK         -
 error: cups-image    CUPS-Image-Lib            REQUIRED        -               -               MISSING    'cups-image needs to be installed'
 error: libnetsnmp-devel SNMP-Networking-SDK       REQUIRED        5.0.9           -               MISSING    'libnetsnmp-devel needs to be installed'
 python-xml           Python-XML-Lib            REQUIRED        -               2.1.0           OK         -
 python-notify        Desktop-notifications     OPTIONAL        -               -               OK         -

------------------------------
|  Compile Time Dependencies |
------------------------------

 error: gcc           gcc-Compiler              REQUIRED        -               4.8.2           MISSING    'gcc needs to be installed'
 error: libtool       Build-tools               REQUIRED        -               -               MISSING    'libtool needs to be installed'
 make                 GNU-Build-tools           REQUIRED        3.0             4.0             OK         -

----------------------
|  Python Extentions |
----------------------

 cupsext              CUPS-Extension            REQUIRED        -               3.13.9          OK         -
 pcardext             PhotoCard-Extension       REQUIRED        -               3.13.9          OK         -
 hpmudext             IO-Extension              REQUIRED        -               3.13.9          OK         -

-----------------------
|  Scan Configuration |
-----------------------

 hpaio                HPLIP-SANE-Backend        REQUIRED        -               3.13.9          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension       REQUIRED        -               3.13.9          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/usb/psc_1200_series?serial=CN419F412Q5H' is a Hewlett-Packard psc_1200_series all-in-one


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                   Model                                     
  -------------------------------------------  ------------------------------------------
  hp:/usb/psc_1200_series?serial=CN419F412Q5H  HP psc 1200 series                       

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Hewlett-Packard-psc-1200-series
-------------------------------
Type: Unknown
Device URI: usb://HP/psc%201200%20series?serial=CN419F412Q5H&interface=1
PPD: /etc/cups/ppd/Hewlett-Packard-psc-1200-series.ppd
PPD Description: HP PSC 1200 Series, hpcups 3.13.9
Printer status: printer Hewlett-Packard-psc-1200-series is idle.  enabled since Ne 4. květen 2014, 18:36:11 CEST
warning: Printer is not HPLIP installed. Printers must use the hp: or hpfax: CUPS backend for HP-Devices.


--------------
| PERMISSION |
--------------

error: groups   user-groups                    Required        -        -        MISSING  lp
USB             None                           Required        -        -        OK       Node:'/dev/bus/usb/005/010' Perm:'  root  scanner rw- rw- rw- rw- rw- r--'
 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
None

Missing Optional Dependencies
-----------------------------
None


USER GROUPS
-----------
error: lp groups need to be added for lojza user

Total Errors: 13
Total Warnings: 1

Run 'hp-doctor' command to prompt and fix the issues.

Done.
:-)

EDIT: výstupy vloženy do kódu
« Poslední změna: Květen 04, 2014, 19:08:43 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #3 kdy: Květen 04, 2014, 19:16:03 »
ad2:
Kód: [Vybrat]
HP Linux Imaging and Printing System (ver. 3.13.9)
Printer Settings Utility ver. 1.0

Copyright (c) 2001-13 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error:  No printers or faxes found.  Please setup a printer or fax and try again.

Byla tiskárna připojená a v zapnutném stavu?
Zkoušel jsi ověřit to nastavení přes hp-printsettings - Image Printing? Co je tam nastaveno? Screenshot?

Prosím, výstupy vkládej po stisknutí # nad oknem příspěvku.

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #4 kdy: Květen 04, 2014, 20:14:05 »
Ahoj, jasně, že ji mám zapnutou. do záložky Image Printing jsem se nedostal. Toto to háže:
« Poslední změna: Květen 04, 2014, 20:26:19 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #5 kdy: Květen 04, 2014, 20:17:07 »
EDIT:screenshot
« Poslední změna: Květen 04, 2014, 20:26:55 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #6 kdy: Květen 04, 2014, 20:20:08 »
a při pokusu nastavit to ve správci zařízení hp to dělá toto:
« Poslední změna: Květen 04, 2014, 20:27:10 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #7 kdy: Květen 04, 2014, 20:37:52 »
Co se týče vkládání výstupů do kódu v příspěvku, vytvořil jsem pro všechny mikro video jak na to. Už jsem to chtěl udělat dávno 8) Bude-li potřeba nějak upravit → kontaktujte mě.

Zde je:
http://wiki.mageia.cz/_media/forum:video:jak_pridat_vystup_do_kodu_v_prispevku.ogg
« Poslední změna: Květen 04, 2014, 20:40:32 od Yullaw »

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #8 kdy: Květen 05, 2014, 15:43:54 »
Mám ještě dotazy, zapni tiskárnu:
  • Co se stane v MCC HardwareNastavit tiskárny, tiskové fronty... ? Vyžádá nějaké balíčky? Je zobrazena tiskárna?
  • Ten problém s tiskem ve photo módu se děje v jakém programu? Děje se to i v jiných programech?
  • Přejdi na stránku http://localhost:631/admin/ a nastav tiskárnu dle obrázku níže. Nebo vyzkoušej jiné nastavení. Ulož parametry. Pokud bude chtít heslo, tak potom Uživatel: root, Heslo: heslo roota. Ulož parametry, test. Pro jistotu mrkni, jak je nastaven tisk pod tím programem, kde se projevuje problém, zda je provedena změna. Tip: projdi i tu stránku pro nastavení CUPS, je tam spousta možností, jako např. Tisk zkušební stránky ap.


Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #9 kdy: Květen 05, 2014, 20:29:59 »
Díky, přes týden nejsem doma, jak přijedu, tak to zkusím, jinak v MCC se to chová standartně, tam to nic nechce. přes ten web cups jsem to už zkoušel, taky bez výsledku, zkusím znovu.
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #10 kdy: Květen 08, 2014, 17:59:23 »
Nazdar, tak jsem zkusil všechno, dokonce jsem se už dostal i do HP-printsettings, do záložky Image printing, zde vše normal. V cups jsou jiné možnosti, než u pixmy, takže tam nebylo co moc měnit.
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Yullaw

  • Global Moderator
  • Hero Member
  • *****
  • Příspěvků: 726
  • Karma: +50/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #11 kdy: Květen 09, 2014, 14:50:09 »
Mám ještě dotazy, zapni tiskárnu:
    ...
    • Ten problém s tiskem ve photo módu se děje v jakém programu? Děje se to i v jiných programech?
    ...

TEST: včerá jsem projel repozitáře a našel jsem novější hplip-3.14.4-0.2.mga4.mrc.src.rpm ve zdrojích http://wiki.mageia.cz/:4:zdroje#mageialinuxru_rusko ... přidej, aktualizuj jen ty balíčky pro tiskárnu, test...

Stále problém? :)

Mageia 6 (64bit), KDE Plasma 5.8.7, Kernel 4.9.56-desktop-1.mga6
Notebook Acer Aspire E1-571G
CPU:Intel® Core i5-3230M 2.6GHz, GPU:Intel+nVidia Optimus GeForce 710M

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #12 kdy: Květen 09, 2014, 19:42:25 »
Zdar, nejsem tak zběhlý, abych toto zvládl, ruský server se mi tam přidal, ale jak z něj dostat onen balíček, to netuším. Zkoušel jsem tisknout foto Gwenview i z GIMPu, dělá to totéž, když jsem si stahl jiné programy, tak se mi nerozjeli vůbec.
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:HP PSC 1210 all-in-one
« Odpověď #13 kdy: Květen 10, 2014, 09:36:24 »
Tak jsem našel balíček hplip 3.14.4 na netu, stáhl, nainstaloval a výsledek je stejný, prostě tisk ve foto kvalitě nejde.Takže asi koupit novou tiskárnu :-)
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]

Lojza

  • Newbie
  • *
  • Příspěvků: 10
  • Karma: +0/-0
    • Zobrazit profil
Re:[Vyřešeno]HP PSC 1210 all-in-one
« Odpověď #14 kdy: Květen 18, 2014, 14:32:14 »
Zdravím všechny, tak se to podařilo konečně nastavit, Yullaw se zapotil, čímž mu děkuji za tři dny práce, a teď se pokusím to shrnout nějak chronologicky, o co šlo a kde byl problém:
Jako první projel balíčky a doplnil ty, které chyběly, použil přitom ruské zdroje uvedené na wiki, poté přes http://localhost:631/ nastavil tiskárnu, mě se objevovaly dvě, kde je třeba vybrat tu, kde není uvedeno připojení usb, dále pak vybrat model, kde se vyskytuje hpijs a nakonec nastavit parametry tisku a uložit. Mělo by to fungovat, mě to jede :-)

Shrnutí kroků:
1. pomocí  hp-check -t zjistit, jaké chybí balíčky a doplnit
2. aktualizovat hplip a hpjip
3. pomocí cups nastavit tiskárnu viz obrázky
4. nastavit v OCM tiskárnu jako výchozí a zkontrolovat parametry tisku
Tak snad vám to pomůže. U mě vyřešeno. :-)


EDIT:[Vyřešeno]
« Poslední změna: Květen 18, 2014, 15:11:25 od Yullaw »
MGA 5 (64bit), kernel-desktop-4.4.26-1.mga5,KDE 4.14.5
CPU: AMD Phenom II X4 905e, 8GB RAM
GPU: RS780L [Radeon 3000]