Autor Téma: HP Photosmart 5510 - Devide comunications eror 5012  (Přečteno 14947 krát)

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
HP Photosmart 5510 - Devide comunications eror 5012
« kdy: Leden 07, 2012, 20:23:04 »
Zdravím,
tak sem opět zde. Pro změnu s novou tiskárnou HP Photosmart 5510. Už při jejím zprovoznění sem měl trochu problémy, protože tiskárna chtěla nejnovější HPLIP. Po jeho nainstalování fungovala v pohodě (tiskárna i skener). Bohžel teď asi po dvou týdnech její nečinosti, sem chtěl něco naskenovat a tiskárna se opět se mnou nebaví (ani skener). Po zapnutí sice nahlásí, že je připojena, ale XSANE hlásí "Otevření zařízení selhalo... Chyba během V/V zařízení". Správe zařízení HP hlásí "Device comunication eror (5012)" :( Za těch 14 dní proběhly asi 3 aktualizace systému. A tak myslím, že se něco pokazilo "díky" tomu.
Zkoušel sem cups přes http://localhost:631 , přes Nastavení HP a i přes ovládací centrum.
Poradí někdo jak to zase zprovoznit? Díky.
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #1 kdy: Leden 07, 2012, 21:46:24 »
Co ti vypise prikaz
Kód: [Vybrat]
hp-check -t
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

starsi

  • Full Member
  • ***
  • Příspěvků: 124
  • Karma: +0/-7
    • Zobrazit profil
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #2 kdy: Leden 07, 2012, 22:06:53 »
Tiež mám ten pocit, že niektoré aktualizácie mi rozhasili funkčný systém.  :(
Mageia 3 x86_64, KDE, Intel Celeron Dual Core 2GHz, vyrovnávacia pamäť 512 KB, Ram DDR 2GB, matičná doska ASUS PP5B-VM (Green), grafická karta Intel 810 later (82G965 Integrated Graphis Controler), zvukovka integrovaná na karte Intel 82801H (ICH8 Family) HD Audio Controler, HD

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #3 kdy: Leden 08, 2012, 08:23:41 »
Co ti vypise prikaz
Kód: [Vybrat]
hp-check -t
Vypíše:
Kód: [Vybrat]
[rellik@localhost ~]$ hp-check -t

HP Linux Imaging and Printing System (ver. 3.11.12)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2011-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine 
if the proper dependencies are installed to successfully compile HPLIP.                                                                 
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built     
HPLIP supplied tarball has the proper dependencies installed to successfully run.                                                       
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and     
run-time dependencies).                                                                                                                 

Saving output in log file: hp-check.log

Initializing. Please wait...
 
---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux localhost 2.6.38.8-desktop-9.mga #1 SMP Tue Dec 20 09:45:44 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Distribution:
unknown 0.0

Checking Python version...
OK, version 2.7.1 installed

Checking PyQt 4.x version...
OK, version 4.8.3 installed.

Checking for CUPS...
Status: scheduler is running
warning: Version: (cups-config) Not available. Unable to determine installed version of CUPS.)                                         
warning: /etc/cups/cupsd.conf file not found or not accessible.                                                                         
                                                                                                                                       
Checking for dbus/python-dbus...                                                                                                       
dbus daemon is running.                                                                                                                 
python-dbus version: 0.83.2                                                                                                             
                                                                                                                                       
                                                                                                                                       
------------------------------------                                                                                                   
| COMPILE AND RUNTIME DEPENDENCIES |                                                                                                   
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS DDK - CUPS driver development kit...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: CUPS image - CUPS image development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: DBus - Message bus system...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libjpeg - JPEG library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libusb - USB library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
OK, found.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
OK, found.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python devel - Python development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 3.11.12 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.11.12

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.11.12
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.11.12
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no
udev-acl-rules=yes
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0



Current contents of '~/.hplip/hplip.conf' file:
[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR"
printer_name = Photosmart_5510
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 10
enable = true
type = 2

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 8.1.2012 08:19:33
version = 3.11.12



--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                            Model                     
  ----------------------------------------------------  ---------------------------
  hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR  HP Photosmart 5510 series 

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Photosmart_5510
---------------
Type: Printer
Device URI: hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
PPD: /etc/cups/ppd/Photosmart_5510.ppd
PPD Description: HP Photosmart 5510 Series, hpcups 3.11.12
Printer status: printer Photosmart_5510 is idle.  enabled since Ne 8. leden 2012, 08:18:22 CET

HP Linux Imaging and Printing System (ver. 3.11.12)
System Tray Status Service ver. 2.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

/usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:127: RuntimeWarning: PyOS_InputHook is not available for interactive use of PyGTK
  set_interactive(1)
error: Unable to communicate with device (code=12): hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
error: Device not found
error: Communication status: Failed


----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
device `hpaio:/usb/Photosmart_5510_series?serial=CN18T046VK05NR' is a Hewlett-Packard Photosmart_5510_series all-in-one


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.



-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0xa111 at 001:005:
    Device URI: hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
    Device node: /dev/bus/usb/001/005
    Mode: 0664
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/005
# owner: root
# group: lp
user::rw-
user:lp:rw-
user:rellik:rw-
group::rw-
mask::rw-
other::r--



---------------
| USER GROUPS |
---------------

rellik

error: User needs to be member of group 'lp' to enable print, scan & fax.
error: User needs to be member of group 'lpadmin' to manage printers.

-----------
| SUMMARY |
-----------

error: 13 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html


Done.
A když spustím správce zařízení HP tak v konzoli to vypíše toto:
Kód: [Vybrat]
HP Linux Imaging and Printing System (ver. 3.11.12)
HP Device Manager ver. 15.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

error: Unable to communicate with device (code=12): hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
error: Device not found
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #4 kdy: Leden 08, 2012, 10:23:04 »
Kód: [Vybrat]
---------------
| USER GROUPS |
---------------

rellik

error: User needs to be member of group 'lp' to enable print, scan & fax.
error: User needs to be member of group 'lpadmin' to manage printers.

pridej se do obou skupin. A pokud to nepomuze, zkus:
Kód: [Vybrat]
chmod 666 /dev/bus/usb/001/005(samozrejme jako root)
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #5 kdy: Leden 08, 2012, 12:00:47 »
Díka za odpověď. Bohužel ale nepomohlo ani jedno :(
Kód: [Vybrat]
[rellik@localhost ~]$ hp-check -t

HP Linux Imaging and Printing System (ver. 3.11.12)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2011-14 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to determine 
if the proper dependencies are installed to successfully compile HPLIP.                                                                 
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already built     
HPLIP supplied tarball has the proper dependencies installed to successfully run.                                                       
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both compile- and     
run-time dependencies).                                                                                                                 

Saving output in log file: hp-check.log

Initializing. Please wait...
 
---------------
| SYSTEM INFO |
---------------

Basic system information:
Linux localhost 2.6.38.8-desktop-9.mga #1 SMP Tue Dec 20 09:45:44 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Distribution:
unknown 0.0

Checking Python version...
OK, version 2.7.1 installed

Checking PyQt 4.x version...
OK, version 4.8.3 installed.

Checking for CUPS...
Status: scheduler is running
warning: Version: (cups-config) Not available. Unable to determine installed version of CUPS.)                                         
warning: /etc/cups/cupsd.conf file not found or not accessible.                                                                         
                                                                                                                                       
Checking for dbus/python-dbus...                                                                                                       
dbus daemon is running.                                                                                                                 
python-dbus version: 0.83.2                                                                                                             
                                                                                                                                       
                                                                                                                                       
------------------------------------                                                                                                   
| COMPILE AND RUNTIME DEPENDENCIES |                                                                                                   
------------------------------------

note: To check for compile-time only dependencies, re-run hp-check with the -c parameter (ie, hp-check -c).
note: To check for run-time only dependencies, re-run hp-check with the -r parameter (ie, hp-check -r).

Checking for dependency: CUPS - Common Unix Printing System...
OK, found.

Checking for dependency: CUPS DDK - CUPS driver development kit...
warning: NOT FOUND! This is an OPTIONAL/RUNTIME ONLY dependency. Some HPLIP functionality may not function properly.

Checking for dependency: CUPS devel- Common Unix Printing System development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: CUPS image - CUPS image development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: DBus - Message bus system...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: gcc - GNU Project C and C++ Compiler...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: GhostScript - PostScript and PDF language interpreter and previewer...
OK, found.

Checking for dependency: libcrypto - OpenSSL cryptographic library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libjpeg - JPEG library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libnetsnmp-devel - SNMP networking library development files...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libpthread - POSIX threads library...
OK, found.

Checking for dependency: libtool - Library building support services...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: libusb - USB library...
error: NOT FOUND! This is a REQUIRED dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: make - GNU make utility to maintain groups of programs...
OK, found.

Checking for dependency: PIL - Python Imaging Library (required for commandline scanning with hp-scan)...
OK, found.

Checking for dependency: PolicyKit - Administrative policy framework...
OK, found.

Checking for dependency: PyQt 4 DBus - DBus Support for PyQt4...
OK, found.

Checking for dependency: Python DBus - Python bindings for DBus...
OK, found.

Checking for dependency: Python devel - Python development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: Python libnotify - Python bindings for the libnotify Desktop notifications...
OK, found.

Checking for dependency: Python XML libraries...
OK, found.

Checking for dependency: Python 2.3 or greater - Required for fax functionality...
OK, found.

Checking for dependency: Python 2.2 or greater - Python programming language...
OK, found.

Checking for dependency: Reportlab - PDF library for Python...
OK, found.

Checking for dependency: SANE - Scanning library...
OK, found.

Checking for dependency: SANE - Scanning library development files...
error: NOT FOUND! This is a REQUIRED/COMPILE TIME ONLY dependency. Please make sure that this dependency is installed before installing or running HPLIP.

Checking for dependency: scanimage - Shell scanning program...
OK, found.

Checking for dependency: xsane - Graphical scanner frontend for SANE...
OK, found.


----------------------
| HPLIP INSTALLATION |
----------------------


Currently installed HPLIP version...
HPLIP 3.11.12 currently installed in '/usr/share/hplip'.

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.11.12

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/HP
ppdbase=/usr/share/ppd
doc=/usr/share/doc/hplip-3.11.12
icon=/usr/share/applications
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv/hp

# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
pp-build=yes
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=no
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=yes
internal-tag=3.11.12
restricted-build=no
ui-toolkit=qt4
qt3=no
qt4=yes
policy-kit=yes
hpijs-only-build=no
lite-build=no
udev-acl-rules=yes
hpcups-only-build=no
hpijs-only-build=no


Current contents of '/var/lib/hp/hplip.state' file:
# hplip.state - HPLIP runtime persistent variables.

[plugin]
installed=0
eula=0



Current contents of '~/.hplip/hplip.conf' file:
[settings]
systray_visible = 0
systray_messages = 0

[last_used]
device_uri = "hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR"
printer_name = Photosmart_5510
working_dir = .

[commands]
scan = /usr/bin/xsane -V %SANE_URI%

[refresh]
rate = 10
enable = true
type = 2

[polling]
enable = false
interval = 5
device_list =

[fax]
voice_phone =
email_address =

[installation]
date_time = 8.1.2012 11:56:42
version = 3.11.12



--------------------------
| DISCOVERED USB DEVICES |
--------------------------

  Device URI                                            Model                     
  ----------------------------------------------------  ---------------------------
  hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR  HP Photosmart 5510 series 

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 
Photosmart_5510
---------------
Type: Printer
Device URI: hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
PPD: /etc/cups/ppd/Photosmart_5510.ppd
PPD Description: HP Photosmart 5510 Series, hpcups 3.11.12
Printer Processing page 1...osmart_5510 now printing Photosmart_5510-17.  enabled since Ne 8. leden 2012, 11:55:52 CET
error: Unable to communicate with device (code=12): hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
error: Device not found
error: Communication status: Failed


----------------------
| SANE CONFIGURATION |
----------------------

'hpaio' in '/etc/sane.d/dll.conf'...
OK, found. SANE backend 'hpaio' is properly set up.

Checking output of 'scanimage -L'...
device `hpaio:/usb/Photosmart_5510_series?serial=CN18T046VK05NR' is a Hewlett-Packard Photosmart_5510_series all-in-one


---------------------
| PYTHON EXTENSIONS |
---------------------

Checking 'cupsext' CUPS extension...
OK, found.

Checking 'pcardext' Photocard extension...
OK, found.

Checking 'hpmudext' I/O extension...
OK, found.

Checking 'scanext' SANE scanning extension...
OK, found.



-----------------
| USB I/O SETUP |
-----------------

Checking for permissions of USB attached printers...

HP Device 0xa111 at 001:005:
    Device URI: hp:/usb/Photosmart_5510_series?serial=CN18T046VK05NR
    Device node: /dev/bus/usb/001/005
    Mode: 0666
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/001/005
# owner: root
# group: lp
user::rw-
user:lp:rw-
user:rellik:rw-
group::rw-
mask::rw-
other::rw-



---------------
| USER GROUPS |
---------------

rellik lp lpadmin

User member of group 'lp'. Enables print/ scan/ fax.
User member of group 'lpadmin'.

-----------
| SUMMARY |
-----------

error: 13 errors and/or warnings.

Please refer to the installation instructions at:
http://hplip.sourceforge.net/install/index.html


Done.
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

starsi

  • Full Member
  • ***
  • Příspěvků: 124
  • Karma: +0/-7
    • Zobrazit profil
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #6 kdy: Leden 08, 2012, 22:13:36 »
Asi by som preformátoval celý disk a urobil inštaláciu celého systému znova, stiahol všetky balíčky v rámci inštalácie a až potom by som po reboote nainštaloval tlačiareň.  :(
Mageia 3 x86_64, KDE, Intel Celeron Dual Core 2GHz, vyrovnávacia pamäť 512 KB, Ram DDR 2GB, matičná doska ASUS PP5B-VM (Green), grafická karta Intel 810 later (82G965 Integrated Graphis Controler), zvukovka integrovaná na karte Intel 82801H (ICH8 Family) HD Audio Controler, HD

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #7 kdy: Leden 08, 2012, 22:17:01 »
Asi by som preformátoval celý disk a urobil inštaláciu celého systému znova, stiahol všetky balíčky v rámci inštalácie a až potom by som po reboote nainštaloval tlačiareň.  :(
Blbost, tohle az v pripade nouze.
Zatim hledam po netu moznosti, kde a proc to stoji a nefunguje.

Zkus jednu vec:
Spust pocitac, ale mej vyplou tiskarnu. Az se nalogujes, tak pust terminal, zapni tiskarnu, pockej tak 10 sekund a  potom napis
dmesg
a dej sem tak poslednich 20--30 radku.
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #8 kdy: Leden 09, 2012, 15:53:23 »
S tím přeinstalováním sem to udělal po výměně tiskárny předchozí (canon mp550) a tuto HP. A přeinstalovávat znovu se mi opravdu nechce...  ???

Jinak tady jsou ty poslední řádky:
Kód: [Vybrat]
Adding 4088504k swap on /dev/sda5.  Priority:-1 extents:1 across:4088504k
NET: Registered protocol family 10
r8169 0000:02:00.0: eth0: link down
r8169 0000:02:00.0: eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready
render error detected, EIR: 0x00000010
  IPEIR: 0x00000000
  IPEHR: 0x01000000
  INSTDONE: 0xfffffffe
  INSTPS: 0x0001e000
  INSTDONE1: 0xffffffff
  ACTHD: 0x00000028
page table error
  PGTBL_ER: 0x00000002
[drm:i915_report_and_clear_eir] *ERROR* EIR stuck: 0x00000010, masking
r8169 0000:02:00.0: eth0: link up
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
NET: Registered protocol family 17
ip_tables: (C) 2000-2006 Netfilter Core Team
nf_conntrack version 0.5.0 (16384 buckets, 65536 max)
ip6_tables: (C) 2000-2006 Netfilter Core Team
NF_TPROXY: Transparent proxy support initialized, version 4.1.0
NF_TPROXY: Copyright (c) 2006-2007 BalaBit IT Ltd.
Netfilter messages via NETLINK v0.30.
ip_set: protocol 6
xt_time: kernel timezone is +0100
ata1.00: configured for UDMA/133
ata1.01: configured for UDMA/100
ata1: EH complete
ata2.00: configured for UDMA/66
ata2.01: configured for UDMA/100
ata2: EH complete
EXT4-fs (sda1): re-mounted. Opts: acl,commit=0
EXT4-fs (sda6): re-mounted. Opts: acl,commit=0
fuse init (API version 7.16)
usb 1-7: new high speed USB device using ehci_hcd and address 5
usb 1-7: New USB device found, idVendor=03f0, idProduct=a111
usb 1-7: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-7: Product: Photosmart 5510 series
usb 1-7: Manufacturer: HP
usb 1-7: SerialNumber: CN18T046VK05NR
scsi3 : usb-storage 1-7:1.2
usblp1: USB Bidirectional printer dev 5 if 1 alt 0 proto 2 vid 0x03F0 pid 0xA111
usbcore: registered new interface driver usblp
scsi 3:0:0:0: Direct-Access     HP       Photosmart 5510  1.00 PQ: 0 ANSI: 5
sd 3:0:0:0: Attached scsi generic sg5 type 0
usb 1-7: usbfs: interface 1 claimed by usblp while 'usb' sets config #1
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #9 kdy: Leden 09, 2012, 16:16:25 »
Ještě dodatek: Spustil sem program na správu tiskáren HP. Opět na mě vyskočila hláška "Chyba komunikace 5012". Zkusil sem znovu ten příkaz dmesg zacykleně to vypíše nevím kolikrát (je toho tolik, že začátek už není ve výpisu) stejnou hlášku:
Kód: [Vybrat]
usb 1-7: reset high speed USB device using ehci_hcd and address 6
usblp1: USB Bidirectional printer dev 6 if 1 alt 0 proto 2 vid 0x03F0 pid 0xA111
usblp1: removed
usb 1-7: reset high speed USB device using ehci_hcd and address 6
usblp1: USB Bidirectional printer dev 6 if 1 alt 0 proto 2 vid 0x03F0 pid 0xA111
usblp1: removed
usb 1-7: reset high speed USB device using ehci_hcd and address 6
usblp1: USB Bidirectional printer dev 6 if 1 alt 0 proto 2 vid 0x03F0 pid 0xA111
usblp1: removed
usb 1-7: reset high speed USB device using ehci_hcd and address 6
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #10 kdy: Únor 12, 2012, 09:53:10 »
Tak po nějaké době hlásím úspěch. Včera sem přeinstaloval celý systém a zaktualizoval. Dnes ráno sem zapnul tiskárnu - nainstalovaly se ovladače. V MCC sem přidal tiskárnu a zatím funguje. Co ovšem nefunguje je skener :( Při přidání to sice nainstalovalo potřebné věci, ale MCC hlásí - Nebyly nalezeny žádné připojené skenery.
Přitom když sem to měl zprovozněné předtím, tak skener fungoval.
No aspoň že zatím jede ta tiskárna. Doufám, že zase nepřestane po nějaké aktualizaci systému...
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

starsi

  • Full Member
  • ***
  • Příspěvků: 124
  • Karma: +0/-7
    • Zobrazit profil
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #11 kdy: Únor 13, 2012, 01:58:52 »
Aj si pred tým formátoval disk? Podľa mňa si mal  :) Aspoň, že ide tlačka.
Mageia 3 x86_64, KDE, Intel Celeron Dual Core 2GHz, vyrovnávacia pamäť 512 KB, Ram DDR 2GB, matičná doska ASUS PP5B-VM (Green), grafická karta Intel 810 later (82G965 Integrated Graphis Controler), zvukovka integrovaná na karte Intel 82801H (ICH8 Family) HD Audio Controler, HD

Peťoš

  • Administrator
  • Hero Member
  • *****
  • Příspěvků: 916
  • Karma: +16/-1
    • Zobrazit profil
    • Peťošův blog
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #12 kdy: Únor 13, 2012, 08:45:25 »
Aj si pred tým formátoval disk? Podľa mňa si mal
Kdyz se instaluje system, vzdy se formatuje root adresar... Nejde to bez toho.
Do it or do not. There is no "try".
Nutné čtení pro všehny! Jak se ptát na fóru: http://wiki.mageia.cz/wiki:jak_se_ptat_na_foru


Peťošův repozitář je na adrese: http://petos.cz/rpms
Fotoblog: http://vzducholode.blogspot.com a http://petos.cz/category/fotky

Rellik

  • Sr. Member
  • ****
  • Příspěvků: 263
  • Karma: +1/-2
  • Kubuntu/64bit
    • Zobrazit profil
    • dv-foto.cz
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #13 kdy: Únor 13, 2012, 21:25:17 »
Kdyz se instaluje system, vzdy se formatuje root adresar... Nejde to bez toho.
Já při instalaci formátuju vždycky celý systémový disk. Mám je v PC dva. Na jednom mám jen systém a na druhém data... :-)
To už je ale diskuze o něčem jiném a neřeší problém s tiskárnou, respektive skenerem... :)
Kubuntu/64bit / Intel Core i3 @3,5GHz, 16Gb ram, intel HD Graphics 4600, HDD 1Tb (data) + 128Gb SSD (system)

starsi

  • Full Member
  • ***
  • Příspěvků: 124
  • Karma: +0/-7
    • Zobrazit profil
Re:HP Photosmart 5510 - Devide comunications eror 5012
« Odpověď #14 kdy: Únor 14, 2012, 02:03:51 »
Kdyz se instaluje system, vzdy se formatuje root adresar... Nejde to bez toho.

Ja mám "pocit", že sa zapisuje aj niečo do home. Pri mojich pokusoch nepomohlo formátovanie len časti root. Keď som preinštalovával len systém problém pretrvával. Keď som sformátoval aj home, až potom celý problém zmizol. Z toho je ten pocit. Skrátka preformátoval som celý disk pred inštaláciou a až na to som znova inštaloval, vrátane rozdelenia disku.
Mageia 3 x86_64, KDE, Intel Celeron Dual Core 2GHz, vyrovnávacia pamäť 512 KB, Ram DDR 2GB, matičná doska ASUS PP5B-VM (Green), grafická karta Intel 810 later (82G965 Integrated Graphis Controler), zvukovka integrovaná na karte Intel 82801H (ICH8 Family) HD Audio Controler, HD